╗ Welcome, guest.
[ Log In :: Register ]

á

[ Track this topic :: Email this topic :: Print this topic ]

Topic: PIUIO issues, recognized on one build but not another.< Next Oldest | Next Newest >
11:09 CST :: 6/24/2015

Guest
Unregistered




Location:

Total


Hi everyone. áNice to make your acquaintances.

I recently bought an arcade cab of Pro 2 and have been messing around with Nirvash's SM HDD Image. áI wanted to update to the newest version of stepmania to keep current and to throw on the Simply Love theme to keep consistent with what i use at home.

For some reason, the PIUIO is listed as a valid and usable input source in the two SM builds that Nirvash included on the HDD image, but in the new build it's not - on the 'test input' screen, it fails to show up as a recognized input source. áI can confirm that the new build is drawing from the same .ini files located in the ~/.Stepmania-5.0/ folder since changes that i've made to the Nirvash builds show up as changes in the configs of the new build and vice versa.

In the preferences.ini file, there is nothing listed for InputDriver nor for the lightsdriver or whatever it's called, but i'm not sure how meaningful that is if it's working for one build vs another.

The next step i'm probably going to take tomorrow when i have a chance to get to the machine (it's not currently stored at my place) is to attempt to recompile/make the legacy PIUIO driver from djpohly's github (i discovered i can't use the new one i think because the kernel version is too old (ref) ), but i thought i'd reach out here too to the community to see if someone else has an idea of what's going wrong.

Fair warning that i am an absolute noob at Linux and am only now coming out of the 'just repeat directions by rote' to 'okay, i think i understand at least 1% of what's going on now' phase.

Thanks!

-dn0

09:38 CST :: 6/26/2015

Guest
Unregistered




Location:

Total


Just an update that i was able to forcefeed the pads to work by actually putting "PIUIO" as an InputDevice in the preferences.ini file.  It unfortunately makes the QWERTY keyboard nonfunctional (i tried listing more than one input device but that didn't work), but that's a minor quibble.

The next thing i want to be able to do is make the front buttons and front USB ports work with the machine - the hope is that updating to the new PIUIO driver may help with that, but i have to update the linux kernel first.

1 replies since 11:09 CST :: 6/24/2015 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

á

Quick Reply: PIUIO issues
Guest

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic

Emoticons :: iB Code
For more options such as extra emoticons and file uploads, use the "add reply" button instead of Quick Reply...